博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
cigarettes
阅读量:5788 次
发布时间:2019-06-18

本文共 861 字,大约阅读时间需要 2 分钟。

 

cigarettes

时间限制:
3000 ms  |  内存限制:
65535 KB
难度:
2
 
描述

Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them

one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.

Now,do you know how many cigarettes can Tom has?

 
输入
First input is a single line,it's n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k.
输出
For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
样例输入
34 310 3100 5
样例输出
514124
#include<stdio.h>
int main()
{
 int n;
 scanf("%d",&n);
 while(n--)
 {
  int m,t,sum=0;
  scanf("%d %d",&m,&t);
  sum+=m;
  while(m>=t)
  {
   sum+=m/t;
   m=m/t+m%t;
  }
  printf("%d\n",sum);
 }
 return 0;
}
代码很简单,就是累加问题。做好循环的问题就能解决它了。

转载于:https://www.cnblogs.com/wangyouxuan/p/3229213.html

你可能感兴趣的文章
20180702搭建青岛RAC记录
查看>>
Spring Security OAuth 实现OAuth 2.0 授权
查看>>
linux文件及简单命令学习
查看>>
dubbo源码分析-架构
查看>>
新 Terraform 提供商: Oracle OCI, Brightbox, RightScale
查看>>
6套毕业设计PPT模板拯救你的毕业答辩
查看>>
IT兄弟连 JavaWeb教程 JSP与Servlet的联系
查看>>
Windows phone 8 学习笔记
查看>>
linux并发连接数:Linux下高并发socket最大连接数所受的各种限制
查看>>
详解区块链中EOS的作用。
查看>>
我的友情链接
查看>>
mysql-error 1236
查看>>
sshd_config设置参数笔记
查看>>
循序渐进Docker(一)docker简介、安装及docker image管理
查看>>
jsp页面修改后浏览器中不生效
查看>>
大恶人吉日嘎拉之走火入魔闭门造车之.NET疯狂架构经验分享系列之(四)高效的后台权限判断处理...
查看>>
信号量实现进程同步
查看>>
Spring4-自动装配Beans-通过构造函数参数的数据类型按属性自动装配Bean
查看>>
win10.64位wnmp-nginx1.14.0 + PHP 5. 6.36 + MySQL 5.5.59 环境配置搭建 结合Thinkphp3.2.3
查看>>
如何查看python selenium的api
查看>>